代寫(xiě)指標編寫(xiě) 編寫(xiě)同花順指標公式 代編公式

時(shí)間:2024-06-19  來(lái)源:  作者: 我要糾錯


X_1:=4*CLOSE;
X_2:=3*LOW;
X_3:=2*HIGH;
X_4:=POW(X_1+X_2+X_3+OPEN,2);
X_5:=SUM(IF(X_4>REF(X_4,1),X_4*VOL,0),55)/SUM(IF(X_4<REF(X_4,1),X_4*VOL,0),55);
X_6:=20*CLOSE+19*LOW+18*HIGH+17*OPEN;
X_7:=100-100/(1+X_5);
X_8:=BARSSINCE(HIGH>10);
X_9:=SLOPE(X_6+X_7,X_8);
X_10:=CLOSE-REF(MA(CLOSE,20),20/2+1);
X_11:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25);
X_12:=MA(X_11,6);
X_13:=4;
X_14:=3;
X_15:=2;
X_16:=1;
X_17:=BARSCOUNT(4*CLOSE+3*LOW+2*HIGH+1*OPEN-X_14*CLOSE-(X_15+X_16)*LOW-(X_13-X_15)*HIGH-(X_15-X_16)*OPEN);
X_18:=CLOSE<30;
X_19:=X_13*LOW+X_14*OPEN-X_15*CLOSE+X_3/X_14!=POW(X_15,2)*HIGH+(X_13-X_16)*OPEN-SQRT(X_13)*CLOSE+HIGH*X_15/(X_15+X_16);
X_20:=VOL/CAPITAL*100<10;
X_21:=X_13*X_14*X_15*X_16+X_13*X_14-X_14*X_15;
X_22:=CLOSE/REF(CLOSE,1)>1.0982 AND REF(CLOSE,1)/REF(CLOSE,2)<1.09 AND OPEN<HIGH;
X_23:=MA(CLOSE,250);
X_24:=CLOSE*1.1>X_23;
X_25:=CLOSE*1.1<X_23*0.8;
X_26:=X_24 OR X_25;
X_27:=REF(LOW,1);
X_28:=SMA(ABS(LOW-X_27),3,1)/SMA(MAX(LOW-X_27,0),3,1)*100;
X_29:=EMA(X_28*10,3);
X_30:=SQRT(X_13)+X_13*X_14-POW(X_15,2)-X_15*X_13;
X_31:=LLV(LOW,13);
X_32:=HHV(X_29,13);
X_33:=EMA(IF(LOW<=X_31,(X_29+X_32*2)/2,0),3)/618;
X_34:=X_28+X_11;
X_35:=X_29+X_10;
X_36:=X_17>X_21;
X_37:=WINNER(CLOSE)*100>=65;
X_38:=MA(CLOSE,X_13+X_9+X_15);
X_39:=MA(X_1-X_14*CLOSE,X_13+X_14+X_15);
X_40:=(X_14*X_15+X_13)*LOW!=(X_14*X_13-X_15)*HIGH;
X_41:=MA(X_31,X_14+X_14+X_13);
X_42:=REF(CLOSE,X_14)<1.095*REF(CLOSE,X_13+X_15) AND REF(CLOSE,X_14)>1.028*REF(CLOSE,X_13+X_15) AND X_39>X_38 AND REF(LOW,X_15+X_14+X_13)<REF(HIGH,X_16+X_15+X_14) AND NOT(REF(CLOSE,X_15*X_14)>REF(CLOSE,X_15*X_13)) AND REF((CLOSE+HIGH+OPEN)/X_13,X_15*X_14)>1.03*REF((CLOSE+HIGH+OPEN)/(X_14+X_15-X_16),X_13+X_15+X_14-X_15-X_16) AND X_35>X_34;
X_43:=X_41>X_39 AND X_33>X_28 AND REF(CLOSE,X_14+X_15)>REF(HIGH,X_15*X_13) AND REF(LOW,X_14*X_15)<0.97*REF(CLOSE,X_12+X_13+X_14) AND BARSLAST(REF(CLOSE,3)>REF(LOW,4)) AND REF(4*CLOSE+OPEN+2*LOW,8)>1.02*REF(OPEN+4*CLOSE+2*HIGH,8);
X_44:=8*CLOSE+7*OPEN+6*HIGH+5*LOW;
X_45:=EMA(IF(LOW<=X_31,(X_29+X_32*2)/2,0),3)/618*(X_14*X_15+X_16)/((X_13+X_14)*X_33)+(X_13*X_14*X_15+X_15);
X_46:=CLOSE*FINANCE(46)/100000000<150 AND BARSCOUNT(VOL)>10;
X_47:=X_1/((X_14-X_15)*CLOSE)*X_45;
X_48:=REF(CLOSE,X_13+X_14)>REF(HIGH,X_13+X_15) AND FILTER(CROSS(X_47,X_16+X_15),X_16+X_15) AND REF((X_13+X_14)*HIGH,X_13+X_14+X_15)<0.97*REF((X_14*X_15+X_16)*LOW,X_15+X_13+X_14);
X_49:=X_47+EMA(IF(LOW<=X_31,(X_29+X_32*2)/2,0),3)/618/X_33-(X_14*X_15+SQRT(X_13)+X_16);
X_50:=X_45/X_14+POW(X_14*(X_15+X_16),2)+X_13*X_14-X_15;
X_51:=X_50/X_49+X_3/HIGH*(8*CLOSE+7*OPEN+6*HIGH+5*LOW)/(X_15*X_50-X_49)/X_44;
X_52:=7*CLOSE+6*OPEN+5*HIGH+(X_13*X_14*X_15*X_16-X_45+X_14*X_15+X_16)*LOW;
X_53:=X_44-X_52;
X_54:=X_53-(CLOSE+OPEN+LOW);
X_55:=X_54*X_51;
X_56:=SUM(IF(X_4>REF(X_4,1),X_4*VOL,0),55)/SUM(IF(X_4<REF(X_4,1),X_4*VOL,0),55)+EMA(X_55,X_30)-X_5;
X_57:=MA(X_11,6)+X_13*X_14*X_15*X_16-X_12-X_14*X_15-X_13-X_15;
X_58:=X_36 AND CROSS(4*CLOSE+3*LOW+2*HIGH+1*OPEN-X_14*CLOSE-(X_15+X_16)*LOW-(X_13-X_15)*HIGH-(X_15-X_16)*OPEN,X_56) AND X_19 AND X_40;
X_59:=X_42 OR X_43 OR X_48 OR X_58;
X_60:=IF(CODELIKE(13),0,1) AND IF(CODELIKE(14),0,1);
X_61:=FILTER(X_59,X_57) AND X_60 AND X_18 AND X_46 AND X_20 AND X_26 AND X_37 AND X_22;
XG:REF(X_61,1) AND CLOSE/REF(CLOSE,1)>1.0682 AND OPEN/REF(CLOSE,1)<1.096;


X_1賦值:4*收盤(pán)價(jià)
X_2賦值:3*最低價(jià)
X_3賦值:2*最高價(jià)
X_4賦值:X_1+X_2+X_3+開(kāi)盤(pán)價(jià)的2乘冪
X_5賦值:如果X_4>1日前的X_4,返回X_4*成交量(手),否則返回0的55日累和/如果X_4<1日前的X_4,返回X_4*成交量(手),否則返回0的55日累和
X_6賦值:20*收盤(pán)價(jià)+19*最低價(jià)+18*最高價(jià)+17*開(kāi)盤(pán)價(jià)
X_7賦值:100-100/(1+X_5)
X_8賦值:首次最高價(jià)>10距今天數
X_9賦值:X_6+X_7的X_8日線(xiàn)性回歸斜率
X_10賦值:收盤(pán)價(jià)-20/2+1日前的收盤(pán)價(jià)的20日簡(jiǎn)單移動(dòng)平均
X_11賦值:最高價(jià)-最低價(jià)的9日簡(jiǎn)單移動(dòng)平均/最高價(jià)-最低價(jià)的9日簡(jiǎn)單移動(dòng)平均的9日簡(jiǎn)單移動(dòng)平均的25日累和
X_12賦值:X_11的6日簡(jiǎn)單移動(dòng)平均
X_13賦值:4
X_14賦值:3
X_15賦值:2
X_16賦值:1
X_17賦值:4*收盤(pán)價(jià)+3*最低價(jià)+2*最高價(jià)+1*開(kāi)盤(pán)價(jià)-X_14*收盤(pán)價(jià)-(X_15+X_16)*最低價(jià)-(X_13-X_15)*最高價(jià)-(X_15-X_16)*開(kāi)盤(pán)價(jià)的有效數據周期數
X_18賦值:收盤(pán)價(jià)<30
X_19賦值:X_13*最低價(jià)+X_14*開(kāi)盤(pán)價(jià)-X_15*收盤(pán)價(jià)+X_3/X_14不等于X_15的2乘冪*最高價(jià)+(X_13-X_16)*開(kāi)盤(pán)價(jià)-X_13的開(kāi)方*收盤(pán)價(jià)+最高價(jià)*X_15/(X_15+X_16)
X_20賦值:成交量(手)/當前流通股本(手)*100<10
X_21賦值:X_13*X_14*X_15*X_16+X_13*X_14-X_14*X_15
X_22賦值:收盤(pán)價(jià)/1日前的收盤(pán)價(jià)>1.0982 AND 1日前的收盤(pán)價(jià)/2日前的收盤(pán)價(jià)<1.09 AND 開(kāi)盤(pán)價(jià)<最高價(jià)
X_23賦值:收盤(pán)價(jià)的250日簡(jiǎn)單移動(dòng)平均
X_24賦值:收盤(pán)價(jià)*1.1>X_23
X_25賦值:收盤(pán)價(jià)*1.1<X_23*0.8
X_26賦值:X_24 OR X_25
X_27賦值:1日前的最低價(jià)
X_28賦值:最低價(jià)-X_27的絕對值的3日[1日權重]移動(dòng)平均/最低價(jià)-X_27和0的較大值的3日[1日權重]移動(dòng)平均*100
X_29賦值:X_28*10的3日指數移動(dòng)平均
X_30賦值:X_13的開(kāi)方+X_13*X_14-X_15的2乘冪-X_15*X_13
X_31賦值:13日內最低價(jià)的最低值
X_32賦值:13日內X_29的最高值
X_33賦值:如果最低價(jià)<=X_31,返回(X_29+X_32*2)/2,否則返回0的3日指數移動(dòng)平均/618
X_34賦值:X_28+X_11
X_35賦值:X_29+X_10
X_36賦值:X_17>X_21
X_37賦值:以收盤(pán)價(jià)計算的獲利盤(pán)比例*100>=65
X_38賦值:收盤(pán)價(jià)的X_13+X_9+X_15日簡(jiǎn)單移動(dòng)平均
X_39賦值:X_1-X_14*收盤(pán)價(jià)的X_13+X_14+X_15日簡(jiǎn)單移動(dòng)平均
X_40賦值:(X_14*X_15+X_13)*最低價(jià)不等于(X_14*X_13-X_15)*最高價(jià)
X_41賦值:X_31的X_14+X_14+X_13日簡(jiǎn)單移動(dòng)平均
X_42賦值:X_14日前的收盤(pán)價(jià)<1.095*X_13+X_15日前的收盤(pán)價(jià) AND X_14日前的收盤(pán)價(jià)>1.028*X_13+X_15日前的收盤(pán)價(jià) AND X_39>X_38 AND X_15+X_14+X_13日前的最低價(jià)<X_16+X_15+X_14日前的最高價(jià) AND 取反 AND X_15*X_14日前的(收盤(pán)價(jià)+最高價(jià)+開(kāi)盤(pán)價(jià))/X_13>1.03*X_13+X_15+X_14-X_15-X_16日前的(收盤(pán)價(jià)+最高價(jià)+開(kāi)盤(pán)價(jià))/(X_14+X_15-X_16) AND X_35>X_34
X_43賦值:X_41>X_39 AND X_33>X_28 AND X_14+X_15日前的收盤(pán)價(jià)>X_15*X_13日前的最高價(jià) AND X_14*X_15日前的最低價(jià)<0.97*X_12+X_13+X_14日前的收盤(pán)價(jià) AND 上次3日前的收盤(pán)價(jià)>4日前的最低價(jià)距今天數 AND 8日前的4*收盤(pán)價(jià)+開(kāi)盤(pán)價(jià)+2*最低價(jià)>1.02*8日前的開(kāi)盤(pán)價(jià)+4*收盤(pán)價(jià)+2*最高價(jià)
X_44賦值:8*收盤(pán)價(jià)+7*開(kāi)盤(pán)價(jià)+6*最高價(jià)+5*最低價(jià)
X_45賦值:如果最低價(jià)<=X_31,返回(X_29+X_32*2)/2,否則返回0的3日指數移動(dòng)平均/618*(X_14*X_15+X_16)/((X_13+X_14)*X_33)+(X_13*X_14*X_15+X_15)
X_46賦值:收盤(pán)價(jià)*自由流通股本(股)/100000000<150 AND 成交量(手)的有效數據周期數>10
X_47賦值:X_1/((X_14-X_15)*收盤(pán)價(jià))*X_45
X_48賦值:X_13+X_14日前的收盤(pán)價(jià)>X_13+X_15日前的最高價(jià) AND X_47上穿X_16+X_15的X_16+X_15日過(guò)濾 AND X_13+X_14+X_15日前的(X_13+X_14)*最高價(jià)<0.97*X_15+X_13+X_14日前的(X_14*X_15+X_16)*最低價(jià)
X_49賦值:X_47+如果最低價(jià)<=X_31,返回(X_29+X_32*2)/2,否則返回0的3日指數移動(dòng)平均/618/X_33-(X_14*X_15+X_13的開(kāi)方+X_16)
X_50賦值:X_45/X_14+X_14*(X_15+X_16)的2乘冪+X_13*X_14-X_15
X_51賦值:X_50/X_49+X_3/最高價(jià)*(8*收盤(pán)價(jià)+7*開(kāi)盤(pán)價(jià)+6*最高價(jià)+5*最低價(jià))/(X_15*X_50-X_49)/X_44
X_52賦值:7*收盤(pán)價(jià)+6*開(kāi)盤(pán)價(jià)+5*最高價(jià)+(X_13*X_14*X_15*X_16-X_45+X_14*X_15+X_16)*最低價(jià)
X_53賦值:X_44-X_52
X_54賦值:X_53-(收盤(pán)價(jià)+開(kāi)盤(pán)價(jià)+最低價(jià))
X_55賦值:X_54*X_51
X_56賦值:如果X_4>1日前的X_4,返回X_4*成交量(手),否則返回0的55日累和/如果X_4<1日前的X_4,返回X_4*成交量(手),否則返回0的55日累和+X_55的X_30日指數移動(dòng)平均-X_5
X_57賦值:X_11的6日簡(jiǎn)單移動(dòng)平均+X_13*X_14*X_15*X_16-X_12-X_14*X_15-X_13-X_15
X_58賦值:X_36 AND 4*收盤(pán)價(jià)+3*最低價(jià)+2*最高價(jià)+1*開(kāi)盤(pán)價(jià)-X_14*收盤(pán)價(jià)-(X_15+X_16)*最低價(jià)-(X_13-X_15)*最高價(jià)-(X_15-X_16)*開(kāi)盤(pán)價(jià)上穿X_56 AND X_19 AND X_40
X_59賦值:X_42 OR X_43 OR X_48 OR X_58
X_60賦值:如果模糊匹配品種代碼,返回0,否則返回1 AND 如果模糊匹配品種代碼,返回0,否則返回1
X_61賦值:X_59的X_57日過(guò)濾 AND X_60 AND X_18 AND X_46 AND X_20 AND X_26 AND X_37 AND X_22
輸出XG:1日前的X_61 AND 收盤(pán)價(jià)/1日前的收盤(pán)價(jià)>1.0682 AND 開(kāi)盤(pán)價(jià)/1日前的收盤(pán)價(jià)<1.096
 






如有需要,請加QQ:88652583 或微信: 88652583


















 

標簽:

掃一掃在手機打開(kāi)當前頁(yè)
  • 上一篇:代寫(xiě)COMM1170、代做c/c++,Python編程語(yǔ)言
  • 下一篇:返回列表
  • 無(wú)相關(guān)信息
    昆明生活資訊

    昆明圖文信息
    蝴蝶泉(4A)-大理旅游
    蝴蝶泉(4A)-大理旅游
    油炸竹蟲(chóng)
    油炸竹蟲(chóng)
    酸筍煮魚(yú)(雞)
    酸筍煮魚(yú)(雞)
    竹筒飯
    竹筒飯
    香茅草烤魚(yú)
    香茅草烤魚(yú)
    檸檬烤魚(yú)
    檸檬烤魚(yú)
    昆明西山國家級風(fēng)景名勝區
    昆明西山國家級風(fēng)景名勝區
    昆明旅游索道攻略
    昆明旅游索道攻略
  • 關(guān)于我們 | 打賞支持 | 廣告服務(wù) | 聯(lián)系我們 | 網(wǎng)站地圖 | 免責聲明 | 幫助中心 | 友情鏈接 |

    Copyright © 2023 kmw.cc Inc. All Rights Reserved. 昆明網(wǎng) 版權所有
    ICP備06013414號-3 公安備 42010502001045